Simplify in-game programming language
For the love of god, please simplify the scripting language! Not all of us are graduates of MIT or have an IQ of 4 Billion! I know a little bit about programming and it seems EXTREMELY redundant and over complicated!
Just as an example? Take this line:
IMyTerminalBlock timer = GridTerminalSystem.GetBlockWithName("Timer Block") as IMyTerminalBlock;
First, get rid of GridTerminalSystem altogether. Of COURSE it's going to be on the grid, you can't interact with something OFF the grid, so this is completely redundant.
Second, get rid of the IMyTerminalBlock (and variations of that). Both off the front and the end of the line. If you're assigning a block to a variable and it's a door, then ... well ... it's a door. If it's a vent, then it's a vent, if it's a timer, it's a timer. You see the logic here? It's unnecessary.
After the changes, the line should read:
timer = GetBlockWithName("Timer Block")
Now doesn't that look cleaner, faster and less error prone? I could probably find other examples of things that need simplifying, but I really shouldn't have to. It's not OUR job to make the game playable. That's YOUR job.